
 Version History

2.1.2
• New additions to the address book (1/2):    Command-] copies the address 
of the sender of the currently open incoming message to the current 
address book.    (You can also invoke this from the Address Book submenu 
under the View menu).

• New additions to the address book (2/2): You may now enter a note or 
memo for each address book entry.    The note is visible only when editing 
address book entries.

• Fixed a problem that sometimes caused BulkRate to hang when 
exchanging mail in the background.

• Fixed a bug that caused BulkRate to crash when dealing with very large 
incoming messages formatted as large blocks of text without spaces or 
return characters; typically BinHexed or UUEncoded files embedded 
withing the message body.

2.1.1
• Fixed a problem with some FirstClass BBSs that caused outgoing 
messages to send improperly and appear as a single charatcer.

• Adjusted the outgoing message splitting code so as not to split in the 
middle of a word; first it attempts to split on a paragraph boundary, then on 
a space character.

• Changed the message sort routine:
      1) When sorting by Conference, the MailBox now always sorts to the top.
      2) All sorts are now secondarily sorted by date/time.
      3) You may now sort items in a list window by clicking on the header at 
the top of the    
              window, just like in the Finder.

2.1 (final release)
• Enhanced the Find text command to look for text in the entire mailbox, 
rather than in just the open window.

• Fixed a bug where a blank subject line in an outgoing message was sent 
as a single random character.

• The Other... menu item under the Size submenu in the Edit menu now 



works again; it apparently stopped working in some earlier version and I 
had not noticed this.

• BulkRate no longer reformats text that has been word wrapped at 80 
characters (typically messages from the Internet).    This is an experiment, I 
may chnage this back in the future, or make it an option.

• Creation dates are now preserved on mailboxes.

• Other minor bug fixes and enhancements.

2.1b9
• Support for extended keyboard editing keys: Cut, Copy, Paste, Page up, 
Page down

• New "Reply special" menu: Reply to sender, conference, or all.

• Improved Address Book functionality 
              - type a name and BulkRate will replace it with the appropriate 
address

• Improved message handling 
              - outgoing mail window can stay open during an exchange
              - you may create, edit and delete outgoing mail during an exchange

• Automatic translation of extended characters in outgoing mail

• Improved connections when using an .fcl log on script

• Option to delete old mail in your mailbox on the server

• Many bug fixes

• Documentation is now in DOCMaker™ form.    This requires no specific 
word processor to read.

2.1b8
• Fixed a bug that sometimes occurred when attempting to turn on "Delete 
mail from server after reading" under Exchange settings in Service setup.

2.1b7
• Fixed a bug that caused messages in mailboxes to become corrupted after
deleting or archiving.



• Fixed a bug in the automatic file downloading that caused BulkRate to fail
to download a file if the filename appeared anywhere else in the message.

• Fixed a bug that caused a crash that occurred under certain 
circumstances when closing a message window.

• Added option to delete mailbox mail on server after retreival.

2.1b6 (was never released to the public)

2.1b5
• Fixed a bug in BR 2.1b3 and 2.1b4 where failing to close all open 
messages before closing the associated message list window or starting a 
mail exchange causes the mailbox file to not be closed properly, which can 
result in file (or disk) errors and crashes when later attempting to open a 
mailbox file.

• BulkRate 2.1b3 and 2.1b4 do not correctly deal with address book files 
opened from the File menu or by double-clicking or dragging-and-dropping. 
Opening address book files this way will cause loss of data.    This has been 
fixed.

• In 2.0.2, 2.1b3 and 2.1b4, closing two windows rapidly with Command-W, 
Command-W will usually result in a crash.    This has been fixed.

• Message list scroll bar problem reported in 2.1b4 has been fixed.

• Other minor fixes and tweaks.

2.1b4
• Scripts:    In certain situations, BulkRate would report "Bad service file" 
and refuse to run scripts that ran fine under earlier versions.    This has been
fixed.

I recommend that you trash any scripts you tried to create or modify under 
2.1b3 and create new ones.

• Service files:    2.1b3 steadfastly refused to recognize incoming and 
outgoing mailboxes in any location other than the same folder as the service
file.    This has been fixed.

Note: to undo the damage caused by this bug in 2.1b3, I recommend using 



the Choose... or Create... buttons in Mailbox settings to reselect the 
mailboxes you wish to use in all of your service files.

• File downloading:    2.1b3 would refuse to download files that were given 
an illegal filename (one containing colons) on the host.    2.1b4 now detects 
this situation and replaces colons with spaces.

• File retreival requests:    
Requests were not saved properly under 2.1b3 if "Use threaded replies" was
turned off, resulting in failure of the retreival.    Fixed.

2.1b3 refused to create a File Retreival Request for files that were attached 
to messages in your auto-download conferences.    Fixed.

New: BulkRate now puts a message in your mailbox which tells you the 
results of your file retreival request.

• Cursor:    the cursor failed to turn into an arrow in scroll bars in 2.1b3; 
instead it remained an I-Beam.    Fixed.

• Text highlighting: Under 2.1b3, text was sometime inappropriately and 
strangely highlighted when switching from window to window or 
application to application.    Fixed.

• Address book: Certain sorting problems fixed; new "Leave address book 
open" checkbox turns off the "Auto-close" feature so you can more easily 
use multiple addresses; you still need to select addresses one at a time. 

• Date sorting is now (finally!) accurate under US script systems; 
international support has not been added but will be added soon.

• "Your screen name:" in Exchange settings can now hold multiple names; 
total number of characters in this field is limited to 255, however, so it will 
hold only a few names.

2.1b3
• File transfers
BulkRate can now upload and download attached files.    You can attach files
to outgoing mail, and you can download files two ways: first, by specifying 
conferences and file sizes for automatic downloads, and secondly, by 
requesting BulkRate to retrieve an attached file on the next mail exchange.   
**File transfers are enabled only on registered copies of BulkRate.**

• .fcl scripting
BulkRate now supports .fcl logon scripts.    If you must use an .fcl script with



FirstClass® Client to connect to a BBS, you can use a copy of the same 
script with BulkRate.

• Threaded replies
An option now exists to insert replies in their proper thread on the 
FirstClass® Server.

• New delete options
Choosing Delete from the Mail menu or clicking the Palette delete button 
now marks the message for later deletion. These messages will be deleted 
when the list window is closed.    You can force delete messages if you wish 
by holding down the option key as you delete.

• Additional service options
You may now instruct BulkRate to automatically delete all read or sent 
messages and/or all messages older than a given number of days.
You can specify default sort options for incoming and outgoing mailboxes.

• Archive current message
When reading a message, you can now archive just that message, or add it 
to an existing archive, without having to find and select it in the list.

• Added "Hold" option to outgoing mail to allow you to mark a message so it
won't be sent till later.

• Address Book window now displays the name of the current address book 
file.

• Incoming and outgoing list windows now zoom in and out properly.

• Mail settings and Modem settings menu items have been replaced by a 
single "Service setup" item; setup dialogs have been revamped to allow 
room for all the new options in BulkRate 2.1.

2.1b3 (cont)
• Replies are now addressed so as to be consistent with the default reply 
preferences for FirstClass® Client:
Replies to messages in your MailBox go to all To: and cc: names as well as 
the originator.    Replies to conference messages are addressed only to the 
conference itself.    If you specify your screen name in the new Service 
setup, your name will automatically be deleted from To and cc lists in a 
reply.

• Lots of minor tweaks and bug fixes.



2.0.2
• Fixed a bug that caused the amount of memory used by BulkRate to slowly
creep up until it ran out of memory.

• Fixed a bug that sometimes caused a crash when closing windows.

• Added more helpful messages when a logon fails.

• BulkRate should no longer choke when it encounters "bare" uploaded 
files; that is, files not attached to a message.

• BulkRate now strips all control characters from the text of outgoing mail: 
inclusion of control characters could cause bizarre behavior as the 
FirstClass® CLUI message editor responded to them as editing commands.

2.0 (final release)
• Removed the serial port status check added in 2.0b7, because it annoyed 
people with fax software and PowerBook 500-series owners.    It may return 
in the future with a preferences setting to turn it on and off.

• BulkRate now strips escape characters from any outgoing mail, which 
cause the FC CLUI text editor to abort.

• "Save as..." suggests the Subject name once again; a bug introduced in 
2.0b7.

• Changes to script routines should now allow a script to quit or shutdown if
a connection fails.

2.0b8
• Fixed a bug that affected non-registered copies of BulkRate 2.0b7, 
resulting in a dialog that claimed that resources has been altered, followed 
by a crash.

• Minor speed-enhancing tweaks to the message read process.

• Improved display of message lists when an item is too wide for its column.

• Should now be compatible with FirstClass® BBSs running the F1 front 
door (for FidoNet).    (This was actually added in 2.0b6, I simply neglected to
mention it.)

2.0b7



• Changed how BulkRate handles timeouts when waiting for message lists 
or messages.    With any luck, those of you who had frequent timeout errors 
using BulkRate on some BBSs will find this version an improvement.

• BulkRate now splits the rare incoming message that is over 32K in length 
into two (or more) messages.

• BulkRate now splits large outgoing messages into multiple parts so as not 
to run afoul of the CLUI text editor, which cannot deal well with messages 
over about 5K in length.

• Address Book window is wider, allowing more characters to be visible.

• Mail log now "autoshrinks" down to under 32K each time you quit 
BulkRate.

• BulkRate Help menu item should now appear under the Apple Menu with 
System 6 - it will still be under the Help menu in System 7.

• Creation date is now displayed in the Outgoing message list window.

• BulkRate now checks the status of the serial port before using it, and asks
if you want to override if it's busy.    (Removed in 2.0 (final))

• BulkRate should now deal with disk full situations with more grace.

• Exchange status window now indicates how many messages remaining to 
be read in the current conference.

• Better "View by Subject" algorithm, thanks to John A. Wasser of BMUG 
Boston.

• 2.0b6 "broke" the Next in Thread function, it should be working again.

2.0b7 (cont)
• Fixed (I hope) a subtle problem when sending long addresses (typically 
Internet addresses) that triggered multiple matches (typically multiple 
Internet gateways).

2.0b6
• Fixed the major bug affecting 68000-based Macs (Plus, SE, Classic, 
PowerBook 100, Portable) which resulted in frequent crashes while trying to
read or otherwise manipulate messages.

• Hold down the option key while deleting to skip the confirmation dialog.



• The Help file is now accessible via the Help menu under System 7 or the 
Apple menu under System 6.

• Fixed problem with horizontal palette causing other windows to not 
activate fully.

• Registration window now waits for you to dismiss it before opening a 
Service window, unless a script is running.

• When launching BulkRate by double-clicking on a Script, instead of 
opening an "untitled service," the first service in the exchange list is 
opened.

• Hitting Delete or Next Thread on an empty list no long crashes BulkRate.

• Fixed a subtle problem that could crop up when closing a window that 
resulted in a rather nasty crash.

2.0b5 (initial release)

Additional Info

Write to <bulkrate-info@pop.com> with the keyword "bulkrate" in the 
subject line, to receive an automated response containing the latest version 
of this readme file.

The BulkRate Server is provided courtesy of Digital Popcorn Online, Los 
Angeles' BBS Plus ™      For more information write <info@pop.com> ("info-
dp" in subject line) or call 818 398-8018.


